请选择 进入手机版 | 继续访问电脑版
快捷导航

报错kubeadm init error: CRI v1 runtime API is not implemented

1
回复
2399
查看
[复制链接]

9

主题

14

帖子

58

积分

注册会员

Rank: 2

积分
58
发表于 2023-8-30 18:36:43 | 显示全部楼层 |阅读模式
老师我升级k8s 1.28.1版本 报错kubeadm init error: CRI v1 runtime API is not implemented 不知是什么原因。奇怪的k8s
回复

使用道具 举报

5

主题

46

帖子

214

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
214
发表于 2023-8-30 18:43:56 | 显示全部楼层
这是旧容器版本的问题。
决绝办法
1.删除已安装的默认配置文件:rm /etc/containerd/config.toml
2.重新启动容器:systemctl重新启动容器
之后kubeadminit命令运行就可以了。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

信息推荐

更多+

最新信息

更多+

峻熙闪答-公众号

官方微信

联系我们:

15131265091

公司地址:河北省保定市竞秀区

Email:1547462309@qq.com

冀ICP备17015524号-1 &技术支持:峻熙闪答